代码参考:

1.用计次循环首 编写

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 i, 整数型
.局部变量 a, 整数型

.计次循环首 (9, i)

    .计次循环首 (i, a)
        编辑框1.加入文本 (到文本 (a) + “x” + 到文本 (i) + “=” + 到文本 (a × i))
        编辑框1.加入文本 (“  ”)
    .计次循环尾 ()
    编辑框1.加入文本 (#换行符)
.计次循环尾 ()

2.用判断循环首 编写

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 i, 整数型
.局部变量 a, 整数型

i = 1

.判断循环首 (i ≤ 9)
    a = 1
    .判断循环首 (a ≤ i)
        编辑框1.加入文本 (到文本 (i) + “x” + 到文本 (a) + “=” + 到文本 (a × i))
        编辑框1.加入文本 (“  ”)
        a = a + 1
    .判断循环尾 ()
    编辑框1.加入文本 (#换行符)
    i = i + 1
.判断循环尾 ()
最后修改:2021 年 01 月 03 日 09 : 54 PM
如果觉得我的文章对你有用,请随意赞赏